
<!DOCTYPE html>
<html lang="en">
<head>
<script type='text/javascript'>var _sf_startpt=(new Date()).getTime()</script>
<meta charset="utf-8">
<title>Late-Night Hosts Pick Apart Kanye West&#039;s Pro-Trump Tweets | Hollywood Reporter</title>
<meta name="viewport" content="width=device-width" />
<meta name="description" content="&quot;I think Kanye West realized he’s too rich to not be Republican,&quot; Trevor Noah quipped on Wednesday." />
<meta name="twitter:site" content="@THR" />
<meta name="twitter:creator" content="@THR" />
<meta name="twitter:url" content="https://www.hollywoodreporter.com/live-feed/late-night-hosts-pick-apart-kanye-wests-pro-trump-tweets-1106007" />
<meta name="twitter:domain" content="https://www.hollywoodreporter.com/" />
<meta name="twitter:title" content="Late-Night Hosts Pick Apart Kanye West&#039;s Pro-Trump Tweets" />
<meta name="twitter:description" content="&quot;I think Kanye West realized he’s too rich to not be Republican,&quot; Trevor Noah quipped on Wednesday." />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:image" content="https://cdn1.thr.com/sites/default/files/imagecache/NFE_Landscape/2018/04/the_late_show_with_stephen_colbert_kanye_maga.jpg" />
<meta property="og:site_name" content="The Hollywood Reporter" />
<meta property="og:title" content="Late-Night Hosts Pick Apart Kanye West&#039;s Pro-Trump Tweets" />
<meta property="og:description" content="&quot;I think Kanye West realized he’s too rich to not be Republican,&quot; Trevor Noah quipped on Wednesday." />
<meta property="og:url" content="https://www.hollywoodreporter.com/live-feed/late-night-hosts-pick-apart-kanye-wests-pro-trump-tweets-1106007" />
<meta property="og:image" content="https://cdn1.thr.com/sites/default/files/2018/04/the_late_show_with_stephen_colbert_kanye_maga.jpg" />
<meta property="og:image:width" content="1296" />
<meta property="og:image:height" content="730" />
<meta property="og:image:type" content="image/jpeg" />
<meta property="og:type" content="article" />
<link rel="author" href="https://plus.google.com/+hollywoodreporter">
<link rel="canonical" href="https://www.hollywoodreporter.com/live-feed/late-night-hosts-pick-apart-kanye-wests-pro-trump-tweets-1106007" />
<link rel="amphtml" href="https://www.hollywoodreporter.com/amp/live-feed/late-night-hosts-pick-apart-kanye-wests-pro-trump-tweets-1106007" />
<link rel="shortcut icon" href=" https://assets.hollywoodreporter.com/assets/1522089328/images/brand/favicon.ico?efaf4a4763bb05b93c96">
<link rel="apple-touch-icon-precomposed" sizes="114x114" href=" https://assets.hollywoodreporter.com/assets/1522089328/images/brand/apple-touch-icon.png?efaf4a4763bb05b93c96">
<script type="text/javascript">
    
    var PGM = window.PGM || {};
    PGM.config = PGM.config || {
        contentHost: "https://www.hollywoodreporter.com",
    };
    (function(PGM) {
        var debug_queue = [];
        PGM.debug = function() {debug_queue.push(arguments);};
        PGM.debug.dump = function() {return debug_queue;}
        PGM.debug.initialCategories = {
                    };
    })(PGM);

    PGM.events = (function() {
        var events_queue = [];
        return {
            trigger: function() {events_queue.push(arguments); },
            get: function() { return events_queue; }
        };
    })();

    PGM.createScript = (function() {
        var q = [], cs = function createScript() { q.push(arguments) };
        cs.dump = function() {return q;};
        return cs;
    })();

    PGM.createScriptTag = (function() {
        var q = [], cs = function createScriptTag() { q.push(arguments) };
        cs.dump = function() {return q;};
        return cs;
    })();

        PGM.tests = [];
    PGM.ads = PGM.ads || {};
    PGM.ads.adUnit = '/';
    PGM.ads.slots = PGM.ads.slots || {};

    PGM.gtmTrackerName = "ua"
</script>
<script src="https://ads.blbrd.co/advertisement.js"></script>

<script>
		    window.CLARITY_GPT_DELAY = 0.01 * 1000;
	
			clarityPageData = {"site_code":"thr","zone":"","disable_initial_load":true,"single_request_mode":true};
		
</script>
<script type="text/javascript">
    (function(){
        window.CLARITY = window.CLARITY || [];
        var ns = document.createElement('script'), s = document.getElementsByTagName('script')[0];
        ns.async = true; ns.type = 'text/javascript'; ns.src = '//lib.pgmcdn.com/clarity-1519742797700.min.js'; s.parentNode.insertBefore(ns, s);
    })();
</script>
<script>
	!function(a9,a,p,s,t,A,g){if(a[a9])return;function q(c,r){a[a9]._Q.push([c,r])}a[a9]={init:function(){q("i",arguments)},fetchBids:function(){q("f",arguments)},setDisplayBids:function(){},_Q:[]};A=p.createElement(s);A.async=!0;A.src=t;g=p.getElementsByTagName(s)[0];g.parentNode.insertBefore(A,g)}("apstag",window,document,"script","//c.amazon-adsystem.com/aax2/apstag.js");

	apstag.init({
        pubID: 3125,
        adServer: 'googletag',
        videoAdServer: 'DFP',
        bidTimeout: 600
    });

	// Tell Clarity not to load a9
    CLARITY.push({
        use: ['header'],
        run: function(header) {
            header.skipJsInject('a9');
        }
    });
</script>
<script>
                CLARITY.push({
                    use: ['header'],
                    run: function(header) {
                                                    var slotData = [
                                                                    ["t_1", "6419/thr.com/feed.article", [[728,90],[970,90],[970,250]], "t", {"980":[[728,90],[970,90],[970,250]],"767":[[728,90]],"0":[[320,50]]}, 0],,                                                                    ["m1_1", "6419/thr.com/feed.article", [[300,250],[300,600]], "m1", {"980":[[300,250],[300,600]],"767":[[300,250]],"0":[]}, 0],,                                                                    ["m2_1", "6419/thr.com/feed.article", [[300,250]], "m2", {"980":[[300,250]],"767":[[300,250]],"0":[[300,250],[320,50]]}, 0],                                                            ];

                            // Add header slots then run,
                            // any slots added after initial run will be processed differently
                            for(var i=0; i<slotData.length; i++) {
                                header.addHeaderSlot.apply(header, slotData[i]);
                            }
                        
                        header.run({"a9":{"account_id":3125}});
                    }
                });
            </script>
<script type="text/javascript">
    
    var PGM = window.PGM || {};
    PGM.mediaQueries = {
        medium: "only screen and (min-width: 768px)",
        large: "only screen and (min-width: 1024px)"
    };
    PGM.ads = PGM.ads || {};
    PGM.preta = false;
</script>
<script>
var THR = THR || {};
THR.config = THR.config || {
    contentHost: "https://www.hollywoodreporter.com",
    debug: "",
    mediaHost: "//cdn1.thr.com"
};
</script>

<script type='text/javascript'>
var googletag = googletag || {};
googletag.cmd = googletag.cmd || [];

var PGM = PGM || {};
PGM.ads = PGM.ads || {};
PGM.ads.data = {"ad_zone":"feed.article","targeting":{"tags":["live feed","television","stephen colbert","trevor noah","late night tv"],"page":"1106007","env":"prod"},"slots":{"m1":{"adUnit":"6419\/thr.com\/feed.article","slotName":"m1","outOfBody":false,"responsive":true,"sizeMapping":{"980":[[300,250],[300,251],[300,600]],"767":[[300,250],[300,251]],"0":[]},"defaultSizes":[[300,250],[300,251],[300,600]],"targetingParameters":{"pos":"m1","page":"1106007","tags":["stephen colbert","trevor noah","late night tv"]},"chartLine":null,"lazyLoad":false},"m2":{"adUnit":"6419\/thr.com\/feed.article","slotName":"m2","outOfBody":false,"responsive":true,"sizeMapping":{"980":[[300,250],[300,252]],"767":[[300,250],[300,252]],"0":[[300,250],[300,252],[300,50],[300,52],[320,50],[320,52]]},"defaultSizes":[[300,250],[300,252]],"targetingParameters":{"pos":"m2","page":"1106007","tags":["stephen colbert","trevor noah","late night tv"]},"chartLine":null,"lazyLoad":false},"t":{"adUnit":"6419\/thr.com\/feed.article","slotName":"t","outOfBody":false,"responsive":true,"sizeMapping":{"980":[[728,90],[980,50],[970,90],[728,91],[980,250],[970,250],[970,66],[970,51],[970,251]],"767":[[728,90],[728,91]],"0":[[300,50],[300,51],[320,50],[320,51],[320,170]]},"defaultSizes":[[728,90],[980,50],[970,90],[728,91],[980,250],[970,250],[970,66],[970,51],[970,251]],"targetingParameters":{"pos":"t","page":"1106007","tags":["stephen colbert","trevor noah","late night tv"]},"chartLine":null,"lazyLoad":false},"a":{"adUnit":"6419\/thr.com\/feed.article","slotName":"a","outOfBody":false,"responsive":true,"sizeMapping":{"980":[[728,90],[728,92]],"767":[[728,90],[728,92]],"0":[[300,50],[300,52],[320,50],[320,52]]},"defaultSizes":[[728,90],[728,92]],"targetingParameters":{"pos":"a","page":"1106007","tags":["stephen colbert","trevor noah","late night tv"]},"chartLine":null,"lazyLoad":false},"o1":{"adUnit":"6419\/thr.com\/feed.article","slotName":"o1","outOfBody":true,"responsive":false,"sizeMapping":[[]],"defaultSizes":[],"targetingParameters":{"pos":"o1","page":"1106007","tags":["stephen colbert","trevor noah","late night tv"]},"chartLine":null,"lazyLoad":false},"m3":{"adUnit":"6419\/thr.com\/feed.article","slotName":"m3","outOfBody":false,"responsive":true,"sizeMapping":{"980":[[300,250],[300,253]],"767":[[300,250],[300,253]],"0":[[300,250],[300,252],[300,50],[300,52],[320,50],[320,52]]},"defaultSizes":[[300,250],[300,253]],"targetingParameters":{"pos":"m3","page":"1106007","tags":["stephen colbert","trevor noah","late night tv"]},"chartLine":null,"lazyLoad":false},"spons1":{"adUnit":"6419\/thr.com\/feed.article","slotName":"spons1","outOfBody":false,"responsive":true,"sizeMapping":{"980":[[300,100],[88,31],[120,60]],"767":[[300,100],[88,31],[120,60]],"0":[[88,31],[120,60]]},"defaultSizes":[[300,100],[88,31],[120,60]],"targetingParameters":{"pos":"spons1","page":"1106007","tags":["stephen colbert","trevor noah","late night tv"]},"chartLine":null,"lazyLoad":false},"lightbox":{"adUnit":"6419\/thr.com\/feed.article","slotName":"lightbox","outOfBody":false,"responsive":true,"sizeMapping":{"980":[[300,250],[300,600]],"767":[[728,90]],"0":[[320,50],[300,50]]},"defaultSizes":[[300,250],[300,600]],"targetingParameters":{"pos":"lightbox","page":"1106007","tags":["stephen colbert","trevor noah","late night tv"]},"chartLine":null,"lazyLoad":false}},"ima_tags":"live feed,television,stephen colbert,trevor noah,late night tv"};
PGM.ads.slots = PGM.ads.slots || {};
PGM.autoplayers = ["VkzEx53Fg","rJIWUc7eW","4kXvKxBFg","r1La1160g","ByDcA7lvg"];

CLARITY = CLARITY || [];

CLARITY.push({
    use: ["ads", "jquery"],
    run: function(Ads, $){
        if( typeof Krux !== 'undefined' ) {
            Ads.addKeyVal("all", "ksg", Krux.segments);
            Ads.addKeyVal("all", "kuid", Krux.user);
        }

        var $embeddedVideos = $('.embedded-content[data-template="video"]');
        if($embeddedVideos.length) {
            // Wish we could do this in the module but it's too late by then
            // for now all embedded videos are autoplay
            Ads.addKeyVal("all", "video", "autoplay");
        } else {
            // Else check if it's one of our autoplay videos
            $('video').each(function () {
                var $vid = $(this),
                    player = $vid.data('player'),
                    account = $vid.data('account');

                if (PGM.autoplayers.indexOf(player) >= 0) {
                    // If there are any auto-play vids stop
                    Ads.addKeyVal("all", "video", "autoplay");
                    return false;
                } else if (account) {
                    Ads.addKeyVal("all", "video", "click-to-play");
                    // if there are click-to-plays there could still be an auto-play somewhere, continue
                }
            });
        }
    }
});
</script>
<script type='text/javascript'>
PGM.ads.adUnit = '/6419/thr.com/feed.article';

CLARITY.push({
    use: ["ads"],
    run: function(Ads){
        Ads.addKeyVal("all", "zone", "feed.article");
                            Ads.addKeyVal("all", "tags", ["live feed","television","stephen colbert","trevor noah","late night tv"]);
                    Ads.addKeyVal("all", "page", "1106007");
                    Ads.addKeyVal("all", "env", "prod");
            }
});
</script>

<script>
    var _comscore = _comscore || [];
    var comscoreVars = {
        c1: "2"
        ,c2: "7395269"
        ,c3: ""
            ,options: { url_append: "comscorekw=live_feed" }
        };
    _comscore.push(comscoreVars);
    </script>
<script type="text/javascript" data-src="https://sb.scorecardresearch.com/beacon.js"></script>
<noscript>
    <img src="http://b.scorecardresearch.com/p?c1=2&c2=7395269&cv=2.0&cj=1" />
</noscript>


<script type="text/javascript">
        var dataLayer = dataLayer || [];
        dataLayer.push({
            'fireGTM': 'on'
                        , 'contentId': '1106007'

                    , 'contentType': 'blog'

                    , 'author': 'Patrick Shanley'

                    , 'category': 'Live Feed'

                    , 'tags': 'Live Feed, Television, Stephen Colbert, Trevor Noah, Late-Night TV'

                    , 'publishDate': '2018042519'

            
        });
        dataLayer.push({'gtm.start':new Date().getTime(),event:'gtm.js'});
        PGM.createScript('//www.googletagmanager.com/gtm.js?id=GTM-WLF8ZZ');
    </script>

<link rel="stylesheet" type="text/css" href="https://assets.hollywoodreporter.com/assets/1522089328/css/blogs.css?efaf4a4763bb05b93c96">
</head>
<body class="blog-post-page" data-template="Story" data-adsitesection="Live Feed" data-twitter-handle="thr">
<div class="header-wrapper ">
<header id="site-header" class="site-header " role="banner">
<div class="site-header__background">
<div class="site-header__contents">
<div class="site-header__bar">
<button class="site-header__nav-toggle"><i class="fa fa-bars"></i></button>
<h1 class="site-header__brand">
<a class="site-header__brand-link" href="/">
<img class="site-header__brand-logo" src="https://assets.hollywoodreporter.com/assets/1522089328/images/brand/thr-logo-white.svg?efaf4a4763bb05b93c96" alt="The&#x20;Hollywood&#x20;Reporter">
<span class="site-header__brand-name">The Hollywood Reporter</span>
</a>
</h1>
<button class="site-header__search-toggle"><i class="fa fa-search"></i></button>
</div>
<nav class="site-header__nav">
<div class="site-header__nav-inner">
<ul class="site-header__nav-items">
<li class="site-header__nav-item ">
<a href=https&#x3A;&#x2F;&#x2F;www.hollywoodreporter.com&#x2F;movies class=site-header__nav-link>
Movies
</a>
</li>
<li class="site-header__nav-item ">
<a href=https&#x3A;&#x2F;&#x2F;www.hollywoodreporter.com&#x2F;node&#x2F;895551 class=site-header__nav-link>
TV
</a>
</li>
<li class="site-header__nav-item ">
<a href=https&#x3A;&#x2F;&#x2F;www.hollywoodreporter.com&#x2F;business class=site-header__nav-link>
Business
</a>
</li>
<li class="site-header__nav-item ">
<a href=https&#x3A;&#x2F;&#x2F;www.hollywoodreporter.com&#x2F;style class=site-header__nav-link>
Style
</a>
</li>
<li class="site-header__nav-item ">
<a href=https&#x3A;&#x2F;&#x2F;www.hollywoodreporter.com&#x2F;node&#x2F;859190 class=site-header__nav-link>
Politics
</a>
</li>
<li class="site-header__nav-item ">
<a href=https&#x3A;&#x2F;&#x2F;www.hollywoodreporter.com&#x2F;tech class=site-header__nav-link>
Tech
</a>
</li>
<li class="site-header__nav-item ">
<a href=https&#x3A;&#x2F;&#x2F;www.hollywoodreporter.com&#x2F;culture class=site-header__nav-link>
Culture
</a>
</li>
<li class="site-header__nav-item ">
<a href=https&#x3A;&#x2F;&#x2F;www.hollywoodreporter.com&#x2F;awards class=site-header__nav-link>
Awards
</a>
</li>
<li class="site-header__nav-item ">
<a href=https&#x3A;&#x2F;&#x2F;www.hollywoodreporter.com&#x2F;video class=site-header__nav-link>
Video
</a>
</li>
<li class="site-header__nav-item collapsed">
<span class=site-header__nav-link>
Sites
</span>
<span class="carat"></span><ul class="site-header__subnav-items">
<li class="site-header__subnav-item ">
<a href=https&#x3A;&#x2F;&#x2F;www.hollywoodreporter.com&#x2F;blogs&#x2F;heat-vision class=site-header__subnav-link>
Heat Vision
</a>
</li>
<li class="site-header__subnav-item ">
<a href=https&#x3A;&#x2F;&#x2F;www.hollywoodreporter.com&#x2F;blogs&#x2F;live-feed class=site-header__subnav-link>
Live Feed
</a>
</li>
<li class="site-header__subnav-item ">
<a href=https&#x3A;&#x2F;&#x2F;www.hollywoodreporter.com&#x2F;node&#x2F;786127 class=site-header__subnav-link>
Esq
</a>
</li>
<li class="site-header__subnav-item ">
<a href=https&#x3A;&#x2F;&#x2F;www.hollywoodreporter.com&#x2F;blogs&#x2F;race class=site-header__subnav-link>
The Race
</a>
</li>
<li class="site-header__subnav-item ">
<a href=https&#x3A;&#x2F;&#x2F;www.hollywoodreporter.com&#x2F;blogs&#x2F;behind-screen class=site-header__subnav-link>
Behind the Screen
</a>
</li>
<li class="site-header__subnav-item ">
<a href=https&#x3A;&#x2F;&#x2F;www.hollywoodreporter.com&#x2F;blogs&#x2F;bastard-machine class=site-header__subnav-link>
Bastard Machine
</a>
</li>
<li class="site-header__subnav-item ">
<a href=https&#x3A;&#x2F;&#x2F;www.hollywoodreporter.com&#x2F;node&#x2F;832202 class=site-header__subnav-link>
Rambling Reporter
</a>
</li>
<li class="site-header__subnav-item ">
<a href=https&#x3A;&#x2F;&#x2F;www.hollywoodreporter.com&#x2F;node&#x2F;832198 class=site-header__subnav-link>
The Fien Print
</a>
</li>
</ul>
</li>
</ul>
<a href="https://subscribe.hollywoodreporter.com/sub/?p=THR&amp;f=saleb&amp;s=IH1402HR12" class="site-header__nav-link site-header__nav-link--subscribe">Subscribe</a>
<a href="/newsletters/subscribe" class="site-header__nav-link site-header__nav-link--newsletter">Newsletters</a>
<ul class="site-header__nav-items site-header__nav-items--site-tools">
<li class="site-header__nav-item collapsed">
<span class=site-header__nav-link--site-tools&#x20;site-header__nav-link class=site-header__nav-link>
Site Tools
</span>
<span class="carat"></span><ul class="site-header__subnav-items">
<li class="site-header__subnav-item ">
<a href=https&#x3A;&#x2F;&#x2F;www.hollywoodreporter.com&#x2F;user&#x2F;login class=site-header__subnav-link>
Login
</a>
</li>
<li class="site-header__subnav-item ">
<a href=https&#x3A;&#x2F;&#x2F;www.hollywoodreporter.com&#x2F;daily&#x2F;archive class=site-header__subnav-link>
Daily Edition
</a>
</li>
</ul>
</li>
</ul>
</div>
</nav>
<form class="site-header__search-form" method="get" accept-charset="UTF-8" action="/search/">
<input class="site-header__search-input" placeholder="Search..." name="keys" maxlength="255">
 <button id="site-header__search-submit" class="site-header__search-submit"><i class="fa fa-times"></i></button>
</form>
</div>
</div>
</header>
<div class="header-wrapper__secondary-header">
<nav class="site-header-links">
<div class="site-header-links__contents">
<a href=http&#x3A;&#x2F;&#x2F;www.hollywoodreporter.com&#x2F;live-feed&#x2F;tv-pilots-2018-complete-guide-1076193 class=site-header-links__link>
Pilots Guide
</a>
<a href=http&#x3A;&#x2F;&#x2F;www.hollywoodreporter.com&#x2F;lists&#x2F;tv-premiere-dates-2018-guide-1047110 class=site-header-links__link>
Premieres
</a>
<a href=http&#x3A;&#x2F;&#x2F;www.hollywoodreporter.com&#x2F;live-feed&#x2F;broadcast-tv-scorecard-2018-complete-guide-whats-new-renewed-canceled-1083031 class=site-header-links__link>
Renewal Scorecard
</a>
<a href=http&#x3A;&#x2F;&#x2F;www.hollywoodreporter.com&#x2F;topic&#x2F;is-us class=site-header-links__link>
This Is Us
</a>
<a href=http&#x3A;&#x2F;&#x2F;www.hollywoodreporter.com&#x2F;topic&#x2F;greys-anatomy class=site-header-links__link>
Grey&#039;s
</a>
<a href=https&#x3A;&#x2F;&#x2F;www.hollywoodreporter.com&#x2F;node&#x2F;761545 class=site-header-links__link>
Empire
</a>
<a href=http&#x3A;&#x2F;&#x2F;www.hollywoodreporter.com&#x2F;topic&#x2F;walking-dead class=site-header-links__link>
Walking Dead
</a>
<a href=http&#x3A;&#x2F;&#x2F;www.hollywoodreporter.com&#x2F;topic&#x2F;game-thrones class=site-header-links__link>
Game of Thrones
</a>
</div>
</nav>
<div class="breaking-news-bar"></div>
</div>
</div>
<div class="site-header__placeholder"></div>
<div class="ad-container leaderboard leaderboard--top">
<div class="leaderboard-wrapper">
<div class="ad_desktop_placeholder">
<div class="ad_desktop_wrapper">
<div class='ad_desktop dfp-ad dfp-ad-t ' data-position='t' data-slot-name="t" data-sizes='[[728,90],[980,50],[970,90],[728,91],[980,250],[970,250],[970,66],[970,51],[970,251]]' data-size-mapping='{"980":[[728,90],[980,50],[970,90],[728,91],[980,250],[970,250],[970,66],[970,51],[970,251]],"767":[[728,90],[728,91]],"0":[[300,50],[300,51],[320,50],[320,51],[320,170]]}' data-lazy-load='' data-refresh='' data-refresh-timer='' data-targeting='{"pos":"t","page":"1106007","tags":["stephen colbert","trevor noah","late night tv"]}' data-ad-unit='6419/thr.com/feed.article' data-trackaction="" data-tracklabel="Ad Click">
</div>
</div>
</div>
</div>
</div>
<div class='ad_desktop dfp-ad dfp-ad-o1 ' data-position='o1' data-slot-name="o1" data-sizes="[[1,1]]" data-out-of-page="true" data-lazy-load='' data-refresh='' data-refresh-timer='' data-targeting='{"pos":"o1","page":"1106007","tags":["stephen colbert","trevor noah","late night tv"]}' data-ad-unit='6419/thr.com/feed.article' data-trackaction="" data-tracklabel="Ad Click">
</div>
<main id="page-content" class="page-content">
<div class="container blog-post url-breadcrumb is-unprocessed is-active  blog-post-media-orientation-landscape blog-post-media-type-image" data-page-title="Late-Night&#x20;Hosts&#x20;Pick&#x20;Apart&#x20;Kanye&#x20;West&#x27;s&#x20;Pro-Trump&#x20;Tweets" data-url-breadcrumb="/live-feed/late-night-hosts-pick-apart-kanye-wests-pro-trump-tweets-1106007" data-content-type="blogPost" data-id="1106007" data-canonical="https://www.hollywoodreporter.com/live-feed/late-night-hosts-pick-apart-kanye-wests-pro-trump-tweets-1106007" data-chartbeatSection="live feed" data-analytics-category="Live Feed" data-analytics-tags="Live Feed, Television, Stephen Colbert, Trevor Noah, Late-Night TV" data-refresh-ads=".dfp-ad-t">
<script>
        window.ima_tags = "live feed,television,stephen colbert,trevor noah,late night tv";
    </script>
<aside class="blog-post__sidebar js__blog-post__sidebar">
<div class="logo-wrap">
<img src="//cdn1.thr.com/sites/default/files/blogicon_livefeed-black2.png" class="logo" alt="" />
</div>
<div class="fix-container">
<div id="js__stories-wrapper" class="stories-wrapper">
<div class="social-container">
<a href="javascript:void(0);" class="fb-square js-pgm-social-share fa-facebook" data-pgm-share="facebook" data-pgm-title="Late-Night&#x20;Hosts&#x20;Pick&#x20;Apart&#x20;Kanye&#x20;West&#x27;s&#x20;Pro-Trump&#x20;Tweets" data-pgm-url="https&#x3A;&#x2F;&#x2F;www.hollywoodreporter.com&#x2F;live-feed&#x2F;late-night-hosts-pick-apart-kanye-wests-pro-trump-tweets-1106007" data-tracklabel="Left Rail - Sharing Facebook"></a>
<a href="javascript:void(0);" class="twitter-square js-pgm-social-share fa-twitter" data-pgm-share="twitter" data-pgm-share="facebook" data-pgm-title="Late-Night&#x20;Hosts&#x20;Pick&#x20;Apart&#x20;Kanye&#x20;West&#x27;s&#x20;Pro-Trump&#x20;Tweets" data-pgm-url="https&#x3A;&#x2F;&#x2F;www.hollywoodreporter.com&#x2F;live-feed&#x2F;late-night-hosts-pick-apart-kanye-wests-pro-trump-tweets-1106007" data-tracklabel="Left Rail - Sharing Twitter"></a>
<a href="https://www.hollywoodreporter.com/print/1106007" target="_blank" class="sharetools-link print print-square fa-print" data-tracklabel="Left Rail - Sharing Print"></a>
<a href="javascript:void(0);" class="js-scroll-to-comments comments-square post-has-comments fa-comment" data-tracklabel="Left Rail - Sharing Comments"></a>
</div>
</div>
</div>
</aside>
<p class="blog-post__byline">
<time datetime="2018-04-25T19:24:37" data-pubdate-value="2018042519" class="publish-date js-publish-date">April 25, 2018</time>
<span class="authors">
7:24pm PT
by
<span class="js-authors-list">
Patrick Shanley </span>
</span>
</p>
<h1 class="blog-post-headline">Late-Night Hosts Pick Apart Kanye West&#039;s Pro-Trump Tweets</h1>
<figure class="blog-post__media main-media" data-media-type="image" data-media-id="1106006">
<img src="https://cdn1.thr.com/sites/default/files/imagecache/scale_crop_768_433/2018/04/the_late_show_with_stephen_colbert_kanye_maga.jpg" alt="&quot;I think Kanye West realized he’s too rich to not be Republican,&quot; Trevor Noah quipped on Wednesday." class="blog-post-main-image media__image main-media__image" />
<figcaption class="media__details-text">
<div class="media__credit">Screengrab/The Late Show with Stephen Colbert</div>
</figcaption>
</figure>
<aside class="blog-post-features">
<div id="blog-post-features-ad" class="ad">
<div class='ad_desktop dfp-ad dfp-ad-m1 ' data-position='m1' data-slot-name="m1" data-sizes='[[300,250],[300,251],[300,600]]' data-size-mapping='{"980":[[300,250],[300,251],[300,600]],"767":[[300,250],[300,251]],"0":[]}' data-lazy-load='' data-refresh='' data-refresh-timer='' data-targeting='{"pos":"m1","page":"1106007","tags":["stephen colbert","trevor noah","late night tv"]}' data-ad-unit='6419/thr.com/feed.article' data-trackaction="" data-tracklabel="Ad Click" data-prepend="Advertisement">
</div>
</div>
<article class="blog-post-features-points">
<h2 class="blog-post-features-header">
In this story
</h2>
<div class="media-grid">
<figure class="blog-post-features-point mg-item">
<a href="/topic/stephen-colbert" title="Stephen Colbert" data-tracklabel="Story Well - In This Story Stephen Colbert">
<img src="https://cdn1.thr.com/sites/default/files/imagecache/nfe_square_383x383/2016/06/stephen_colbert_gun_control_rap_h_2016.jpg" alt="Stephen Colbert" class="blog-post-featured-point-image" />
<figcaption class="blog-post-features-point-summary">Stephen Colbert</figcaption>
</a>
</figure>
<figure class="blog-post-features-point mg-item">
<a href="/topic/trevor-noah" title="Trevor Noah" data-tracklabel="Story Well - In This Story Trevor Noah">
<img src="https://cdn1.thr.com/sites/default/files/imagecache/nfe_square_383x383/2015/11/_the_war_on_christmas_continues_-_h_2015.jpg" alt="Trevor Noah" class="blog-post-featured-point-image" />
<figcaption class="blog-post-features-point-summary">Trevor Noah</figcaption>
</a>
</figure>
<figure class="blog-post-features-point mg-item">
<a href="/topic/late-night-tv" title="Late-Night TV" data-tracklabel="Story Well - In This Story Late-Night TV">
<img src="https://cdn1.thr.com/sites/default/files/imagecache/nfe_square_383x383/2017/02/colbert_never_fjorget.jpg" alt="Late-Night TV" class="blog-post-featured-point-image" />
<figcaption class="blog-post-features-point-summary">Late-Night TV</figcaption>
</a>
</figure>
</div>
</article>
</aside>
<aside class="blog-post-deck">
<div class="social-container">
<a href="javascript:void(0);" class="fb-square js-pgm-social-share fa-facebook" data-pgm-share="facebook" data-pgm-title="Late-Night&#x20;Hosts&#x20;Pick&#x20;Apart&#x20;Kanye&#x20;West&#x27;s&#x20;Pro-Trump&#x20;Tweets" data-pgm-url="https&#x3A;&#x2F;&#x2F;www.hollywoodreporter.com&#x2F;live-feed&#x2F;late-night-hosts-pick-apart-kanye-wests-pro-trump-tweets-1106007" data-tracklabel="Story Well - Sharing Facebook"></a>
<a href="javascript:void(0);" class="twitter-square js-pgm-social-share fa-twitter" data-pgm-share="twitter" data-pgm-share="facebook" data-pgm-title="Late-Night&#x20;Hosts&#x20;Pick&#x20;Apart&#x20;Kanye&#x20;West&#x27;s&#x20;Pro-Trump&#x20;Tweets" data-pgm-url="https&#x3A;&#x2F;&#x2F;www.hollywoodreporter.com&#x2F;live-feed&#x2F;late-night-hosts-pick-apart-kanye-wests-pro-trump-tweets-1106007" data-tracklabel="Story Well - Sharing Twitter"></a>
<a href="https://www.hollywoodreporter.com/print/1106007" target="_blank" class="sharetools-link print print-square fa-print" data-tracklabel="Story Well - Sharing Print"></a>
<a href="javascript:void(0);" class="js-scroll-to-comments comments-square post-has-comments fa-comment" data-tracklabel="Story Well - Sharing Comments"></a>
</div>
<div class="blog-post-summary">
&quot;I think Kanye West realized he’s too rich to not be Republican,&quot; Trevor Noah quipped on Wednesday.
</div>
</aside>
<div id="blog-post-body-ad" class="ad">
</div>
<article class="blog-post-body js-fitvids-content">
<p>Late-night hosts took issues with Kanye West&#39;s <a href="https://www.hollywoodreporter.com/news/kanye-west-doubles-down-trump-support-he-is-my-brother-1105749" target="_blank">pro-Donald Trump tweets </a>on Wednesday.</p>
<p>&quot;You don&#39;t have to agree with trump but the mob can&#39;t make me not love him,&quot; West tweeted, among many other pro-Trump messages which asserted that the president was the rapper&#39;s &quot;brother&quot; and that both West and Trump are &quot;dragon energy.&quot;&nbsp; West previously made a pilgrimage to Trump Tower in December 2016.</p>
<p>On the <em>Late Show</em>, host Stephen Colbert showed an image of West&rsquo;s tweeted picture of a Trump-signed &ldquo;Make America Great Again&rdquo; hat captioned with multiple fire emojis. Colbert commented, &ldquo;That&rsquo;s fitting, because that&rsquo;s how many times I&rsquo;d set that hat on fire.&rdquo;</p>
<p>The CBS host went on say that the rapper was &ldquo;lobbying&rdquo; for a job as Trump&rsquo;s communications director. &ldquo;He can just change his name to Kellyanne Kanye,&rdquo; Colbert quipped.</p>
<p>Noting West&rsquo;s comments that Trump is &ldquo;his brother,&rdquo; Colbert said, &ldquo;I&rsquo;m your brother, too, and, I just want to say, brother to brother, put the phone down.&rdquo;</p>
<blockquote class="twitter-video" data-lang="en">
<p dir="ltr" lang="en">TONIGHT: Stephen noticed <a href="https://twitter.com/hashtag/Kanye?src=hash&amp;ref_src=twsrc%5Etfw">#Kanye</a> getting &quot;kinda political&quot; on Twitter today. What&#39;s up <a href="https://twitter.com/kanyewest?ref_src=twsrc%5Etfw">@KanyeWest</a>? Are you angling for a job in the Trump White House? <a href="https://twitter.com/hashtag/LSSC?src=hash&amp;ref_src=twsrc%5Etfw">#LSSC</a> <a href="https://t.co/pKTSxnOTVe">pic.twitter.com/pKTSxnOTVe</a></p>
&mdash; The Late Show (@colbertlateshow) <a href="https://twitter.com/colbertlateshow/status/989318279524040704?ref_src=twsrc%5Etfw">April 26, 2018</a></blockquote>
<script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script><p>Over on the <em>Daily Show</em>, Trevor Noah was confused by West&#39;s comments, but posited a reasoning behind the tweets. &quot;I don&rsquo;t even know what happened here. I think Kanye West realized he&rsquo;s too rich to not be Republican,&quot; Noah said.</p>
<p>Noah then referenced West&#39;s infamous comments about then-president George W. Bush in 2005: &quot;You know what&rsquo;s crazy is that George Bush hates black people &hellip; but he&rsquo;s the same guy who loves Trump? When George Bush sees this on Twitter he&rsquo;s going to be like, &lsquo;What the f&mdash;? I know I was a bad president, but this guy&rsquo;s friends with Nazis.&rdquo;</p>
<div style="background-color:#000000;width:520px;">
<div style="padding:4px;">
<iframe allowfullscreen="true" frameborder="0" height="288" src="//media.mtvnservices.com/embed/mgid:arc:video:comedycentral.com:4e2643bb-0cca-4e87-9274-0eb4e514e178" width="512"></iframe></div>
</div>
<p>On TBS, host Conan O&#39;Brien joked during his monologue, &quot;Kanye called Trump, &#39;my brother,&#39; and Trump called Kanye &#39;my one black supporter.&#39; &rdquo;</p>
<p>Jimmy Kimmel similarly quipped, &quot;Now Donald Trump has two black friends. I hope Ben Carson doesn&rsquo;t get jealous!&quot;</p>
<p>Like Colbert, Kimmel noted that West was on his way to a Cabinet position. &quot;And just like that, Kanye West became our new Secretary of State,&quot; the <em>Jimmy Kimmel Live!</em> host said.</p>
<p>
<div class="embedded-content" data-nid="1106009" data-nodetype="news" data-template="readmore" data-amp-enabled="1">
<script type="application/json">
        {
          "nid": 1106009,
          "type": "news",
          "title": "Did Kanye West Just Kill His Brand?",
          "path": "https://www.hollywoodreporter.com/news/did-kanye-west-just-kill-his-brand-1106009","media": {"width":1296,"height":730,"extension":"jpg","file_size":214932,"mime_type":"image\/jpeg","type":"image","path":"sites\/default\/files\/2018\/04\/kanye_west.jpg","orientation":"landscape","id":null,"caption":"Kanye West","credit":"Neilson Barnard\/Getty Images for adidas"},
          "relative-path": "/news/did-kanye-west-just-kill-his-brand-1106009"
        }
      </script>
</div></p>
<footer class="blog-post-tags">
<a href="/topic/stephen-colbert" data-tracklabel="Story Well - Bottom Tags Stephen Colbert">Stephen Colbert</a>
<a href="/topic/trevor-noah" data-tracklabel="Story Well - Bottom Tags Trevor Noah">Trevor Noah</a>
<a href="/topic/late-night-tv" data-tracklabel="Story Well - Bottom Tags Late-Night TV">Late-Night TV</a>
</footer>
</article>
<div class="blog-post-footer-ad">
<div class='ad_desktop dfp-ad dfp-ad-m2 ' data-position='m2' data-slot-name="m2" data-sizes='[[300,250],[300,252]]' data-size-mapping='{"980":[[300,250],[300,252]],"767":[[300,250],[300,252]],"0":[[300,250],[300,252],[300,50],[300,52],[320,50],[320,52]]}' data-lazy-load='' data-refresh='' data-refresh-timer='' data-targeting='{"pos":"m2","page":"1106007","tags":["stephen colbert","trevor noah","late night tv"]}' data-ad-unit='6419/thr.com/feed.article' data-trackaction="" data-tracklabel="Ad Click" data-prepend="Advertisement">
</div>
</div>
<section class="blog-post-author-section">
<div class="social-container">
<a href="javascript:void(0);" class="fb-square js-pgm-social-share fa-facebook" data-pgm-share="facebook" data-pgm-title="Late-Night&#x20;Hosts&#x20;Pick&#x20;Apart&#x20;Kanye&#x20;West&#x27;s&#x20;Pro-Trump&#x20;Tweets" data-pgm-url="https&#x3A;&#x2F;&#x2F;www.hollywoodreporter.com&#x2F;live-feed&#x2F;late-night-hosts-pick-apart-kanye-wests-pro-trump-tweets-1106007" data-tracklabel="Story Well - Sharing Facebook"></a>
<a href="javascript:void(0);" class="twitter-square js-pgm-social-share fa-twitter" data-pgm-share="twitter" data-pgm-share="facebook" data-pgm-title="Late-Night&#x20;Hosts&#x20;Pick&#x20;Apart&#x20;Kanye&#x20;West&#x27;s&#x20;Pro-Trump&#x20;Tweets" data-pgm-url="https&#x3A;&#x2F;&#x2F;www.hollywoodreporter.com&#x2F;live-feed&#x2F;late-night-hosts-pick-apart-kanye-wests-pro-trump-tweets-1106007" data-tracklabel="Story Well - Sharing Twitter"></a>
<a href="https://www.hollywoodreporter.com/print/1106007" target="_blank" class="sharetools-link print print-square fa-print" data-tracklabel="Story Well - Sharing Print"></a>
<a href="javascript:void(0);" class="js-scroll-to-comments comments-square post-has-comments fa-comment" data-tracklabel="Story Well - Sharing Comments"></a>
</div>
<div class="blog-post-author">
<img src="https://cdn1.thr.com/sites/default/files/imagecache/nfe_square_383x383/2016/12/aaeaaqaaaaaaaafiaaaajgyxmtvhnmm0ltcynjetngvmmy1iyzvllwq4odlhyzqwzjyznw.jpg" alt="Patrick Shanley" class="blog-post-author-image" />
<div class="blog-post-author-details">
<p class="blog-post-author-name">
Patrick Shanley</p>
<a href="mailto:patrick.shanley@THR.com" class="blog-post-author-email fa-envelope" data-tracklabel="Story Well - Author Email">patrick.shanley@THR.com</a>
<a href="https://twitter.com/@pshanley88" class="blog-post-author-twitter fa-twitter" data-tracklabel="Story Well - Author Twitter">@pshanley88</a>
</div>
</div>
</section>
<section class="blog-post-syndication-section">
<div class="zergnet-holder" data-placement="article"></div>
<div class="ad_desktop dfp-ad" data-position="zergnet" data-sizes="[[4,4]]" data-lazy-load="0" data-refresh="0" data-refresh-timer="0" data-swap="" data-load-order="" data-ad-unit="/6419/thr.com/zergnet">
</div> </section>
<div>
<button class="js-show-disqus-comments show-disqus-comments" data-tracklabel="Show Comments - Late-Night Hosts Pick Apart Kanye West&#039;s Pro-Trump Tweets">Comments</button>
<div id="disqus-comments" class="disqus">
<div id="disqus_thread" class="disqus-comments-wrapper"></div>
<script type="text/javascript">
        var disqus_shortname = 'hollywoodreporter';
        var disqus_identifier = 'node/1106007';
        var disqus_title = 'Late-Night Hosts Pick Apart Kanye Wests Pro-Trump Tweets';
        var disqus_url = 'https://www.hollywoodreporter.com/live-feed/late-night-hosts-pick-apart-kanye-wests-pro-trump-tweets-1106007';
    </script>
<script data-src="//hollywoodreporter.disqus.com/embed.js"></script>
<a href="https://disqus.com" class="dsq-brlink">comments powered by <span class="logo-disqus">Disqus</span></a>
</div>
</div>
<div class="blog-post__topic-block-container">
<section class="blog-post__topic-block-wrap" data-id="1106007">

<div class="  full-width-promo-none ">
<section class="blog-post__topic-block">
<div class="topic-block-container">
<header class="topic-block-header">
<h2 class="topic-block-headline">TV Scorecards</h2>
</header>
<ul>
<li class="topic-block-story">
<a class="topic-block-link" href="https://www.hollywoodreporter.com/live-feed/broadcast-tv-scorecard-2018-complete-guide-whats-new-renewed-canceled-1083031" data-tracklabel="TV Scorecards Topic Block - Item 1">
<img src="https://cdn1.thr.com/sites/default/files/imagecache/NFE_Landscape/2018/02/tv_scorecard_2018-split_publicity-h_2018.jpg" class="topic-block-story-image " />
<h3 class="topic-block-story-headline">Broadcast TV Scorecard 2018: Complete Guide to What&#039;s New, Renewed and Canceled</h3>
</a>
</li>
<li class="topic-block-story">
<a class="topic-block-link" href="https://www.hollywoodreporter.com/live-feed/tv-pilots-2018-complete-guide-1076193" data-tracklabel="TV Scorecards Topic Block - Item 2">
<img src="https://cdn1.thr.com/sites/default/files/imagecache/NFE_Landscape/2018/01/nathan_fillion_gabrielle_union_and_lee_daniels_split.jpg" class="topic-block-story-image " />
<h3 class="topic-block-story-headline">TV Pilots 2018: The Complete Guide</h3>
</a>
</li>
<li class="topic-block-story">
<a class="topic-block-link" href="https://www.hollywoodreporter.com/lists/tv-premiere-dates-2018-guide-1047110" data-tracklabel="TV Scorecards Topic Block - Item 3">
<img src="https://cdn1.thr.com/sites/default/files/imagecache/NFE_Landscape/2018/02/westwroldembed.jpg" class="topic-block-story-image " />
<h3 class="topic-block-story-headline">TV Premiere Dates 2018: The Complete Guide</h3>
</a>
</li>
</ul>
</div>
</section>
</div>
</section>
</div>
</div>
<div class="autoload-direct-render" data-url-prefix="/fe_data" data-url="/live-feed/here-now-starring-tim-robbins-canceled-at-hbo-1104986" data-content-type="blogPost"></div>
</main>

<footer id="site-footer" class="site-footer">
<div class="container">
<div class="branding column">
<div class="brand">
<a href="/" title="The Hollywood Reporter" rel="home" class="logo" data-tracklabel="Drip Pan Footer - THR Logo">The Hollywood Reporter</a>
</div>
<p class="copyright date">
&copy; 2018 The Hollywood Reporter
<br>
All rights reserved.
</p>
<p class="copyright terms">
<a href="/legal/terms">Terms of Use</a> |
<a href="/legal/privacy">Privacy</a> |
<a href="/sitemap">Sitemap</a> |
<a href="/legal/about-our-ads">About Our Ads</a>
 </p>
</div>
<div class="affiliate column">
<ul>
<li>
<a href="/about/about" data-tracklabel="Drip Pan Footer - About Us">About Us</a>
</li>
<li>
<a href="/user/login" data-tracklabel="Drip Pan Footer - Login">Login</a>
</li>
<li>
<a href="/daily/archive" data-tracklabel="Drip Pan Footer - Daily Edition">Daily Edition</a>
</li>
<li>
<a href="https://www.hollywoodreporter.com/subscribe3" data-tracklabel="Drip Pan Footer - Subscribe">Subscribe</a>
</li>
<li>
<a href="/services" data-tracklabel="Drip Pan Footer - Subscriber Services">Subscriber Services</a>
</li>
<li>
<a href="//shop.hollywoodreporter.com" data-tracklabel="Drip Pan Footer - Back Issues">Back Issues</a>
</li>
<li>
<a href="/ad/contacts" data-tracklabel="Drip Pan Footer - Advertising">Advertising</a>
</li>
<li>
<a href="/contact" data-tracklabel="Drip Pan Footer - Contact Us">Contact Us</a>
</li>
<li>
<a href="http://prometheusglobalmedia.applytojob.com/" target="_blank" data-tracklabel="Drip Pan Footer - Careers">Careers</a>
</li>
<li>
<a href="/industry-jobs" data-tracklabel="Drip Pan Footer - Industry Jobs">Industry Jobs</a>
</li>
</ul>
</div>
<div class="follow column">
<ul>
<li>
Follow Us On
<a href="https://twitter.com/thr" target="_blank" data-tracklabel="Drip Pan Footer - Twitter">Twitter</a>
</li>
<li>
Find Us On
<a href="https://www.facebook.com/HollywoodReporter" target="_blank" data-tracklabel="Drip Pan Footer - Facebook">Facebook</a>
</li>
<li>
Watch Us On
<a href="https://www.youtube.com/thrnetwork" target="_blank" data-tracklabel="Drip Pan Footer - YouTube">Youtube</a>
</li>
</ul>
</div>
<div class="partner column">
<div class="publications">
<p>Our affiliate publications</p>
<ul>
<li>
<a href="http://www.billboard.com/" target="_blank" class="footer logo billboard" data-tracklabel="Drip Pan Footer - Billboard">Billboard</a>
</li>
<li>
<a href="https://www.vibe.com/" target="_blank" class="foot logo vibe" data-tracklabel="Drip Pan Footer - Vibe">Vibe</a>
</li>
<li>
<a href="https://www.spin.com/" target="_blank" class="foot logo spin" data-tracklabel="Drip Pan Footer - Spin">Spin</a>
</li>
<li>
<a href="https://www.stereogum.com/" target="_blank" class="foot logo stereogum" data-tracklabel="Drip Pan Footer - Stereogum">Stereogum</a>
</li>
</ul>
</div>
</div>
</div>
</footer>
<script type="application/ld+json">
{
    "@context": "http://schema.org",
    "@type": "Organization",
    "name": "The Hollywood Reporter",
    "url": "http://www.hollywoodreporter.com",
    "logo": "http://www.hollywoodreporter.com/assets/images/brand/thr-logo.gif",
    "sameAs" : [
        "https://www.youtube.com/user/thrnetwork",
        "https://twitter.com/thr",
        "https://www.facebook.com/HollywoodReporter",
        "https://instagram.com/hollywoodreporter/"
    ]
}
</script>
<script type="text/javascript" src="https://assets.hollywoodreporter.com/assets/1522089328/js/commons.bundle.js?efaf4a4763bb05b93c96"></script>
<script type="text/javascript" src="https://assets.hollywoodreporter.com/assets/1522089328/js/transition.bundle.js?efaf4a4763bb05b93c96"></script>
<script type="text/javascript" src="https://assets.hollywoodreporter.com/assets/1522089328/js/templates.js?efaf4a4763bb05b93c96"></script>
<script type="text/javascript" src="https://assets.hollywoodreporter.com/assets/1522089328/js/vendor.js?efaf4a4763bb05b93c96"></script>
<script type="text/javascript" src="https://assets.hollywoodreporter.com/assets/1522089328/js/home.bundle.js?efaf4a4763bb05b93c96"></script>
<script type="text/javascript" src="https://assets.hollywoodreporter.com/assets/1522089328/js/thr.js?efaf4a4763bb05b93c96"></script>
<script type="text/javascript" src="https://assets.hollywoodreporter.com/assets/1522089328/js/thr-blog.js?efaf4a4763bb05b93c96"></script>
<div id="fb-root"></div>
<script type="text/javascript">
    PGM.createScriptTag("//connect.facebook.net/en_US/sdk.js#xfbml=1&version=v2.6&appId=303838389949803");
</script>
<script type="text/javascript">var __st_loadLate=true;</script>
<meta name="sailthru.title" content="Late-Night Hosts Pick Apart Kanye West&#039;s Pro-Trump Tweets">
<meta name="sailthru.description" content="&quot;I think Kanye West realized he’s too rich to not be Republican,&quot; Trevor Noah quipped on Wednesday.">
<meta name="sailthru.author" content="Patrick Shanley">
<meta name="sailthru.channel" content="Live Feed">
<meta name="sailthru.vertical" content="Live Feed">
<meta name="sailthru.date" content="2018-04-25 19:24:37">
<meta name="sailthru.tags" content="Live Feed, Television, Stephen Colbert, Trevor Noah, Late-Night TV">
<script type="text/javascript">
    PGM.createScript("//ak.sail-horizon.com/horizon/v1.js", function() {
        if (window.Sailthru) {
            PGM.debug('sailthru', 'Running Sailthru.track for', 'https://www.hollywoodreporter.com/live-feed/late-night-hosts-pick-apart-kanye-wests-pro-trump-tweets-1106007');
            Sailthru.track({
                domain: 'horizon.hollywoodreporter.com',
                spider: true,
                track_url: true,
                url: 'https://www.hollywoodreporter.com/live-feed/late-night-hosts-pick-apart-kanye-wests-pro-trump-tweets-1106007'
            });
        }
        else {
            PGM.debug('sailthru', 'No window.Sailthru');
        }
    });
    </script>
<script type="text/javascript">
    PGM.createScript("//dnn506yrbagrg.cloudfront.net/pages/scripts/0021/6696.js?"+Math.floor(new Date().getTime()/3600000));
</script>

<script type='text/javascript'>
    var _sf_async_config={};
    /** CONFIGURATION START **/
    _sf_async_config.uid = 3388;
    _sf_async_config.domain = 'hollywoodreporter.com';
    _sf_async_config.useCanonical = true;
    _sf_async_config.authors = "Patrick Shanley";
    _sf_async_config.sections = "live feed";
    /** CONFIGURATION END **/
    PGM.createScript('//static.chartbeat.com/js/chartbeat.js');
</script>



<script class="kxct" data-id="JtjzpxpZ" data-timing="async" data-version="1.9" type="text/javascript">
    window.Krux||((Krux=function(){Krux.q.push(arguments)}).q=[]);
    (function(){
        var k=document.createElement('script');k.type='text/javascript';k.async=true;
        k.src=(location.protocol==='https:'?'https:':'http:')+'//cdn.krxd.net/controltag/JtjzpxpZ.js';
        var s=document.getElementsByTagName('script')[0];s.parentNode.insertBefore(k,s);
    }());
</script>

<script class="kxint" type="text/javascript">
window.Krux||((Krux=function(){Krux.q.push(arguments);}).q=[]);
(function(){
  function retrieve(n){
    var k= 'kx'+''+n, ls=(function(){
      try {
        return window.localStorage;
      } catch(e) {
        return null;
      }
    })();
    if (ls) {
        return ls[k] || '';
    } else if (navigator.cookieEnabled) {
        var m = document.cookie.match(k+'=([^;]*)');
        return (m && unescape(m[1])) || '';
    } else {
        return '';
    }
  }
  Krux.user = retrieve('user');
  var segs = retrieve('segs');
  Krux.segments = segs ? segs.split(',') : [];
})();
</script>

<script>
    window.CLARITY = window.CLARITY || [];
</script>
<div class="ad_clarity" data-out-of-page="true" style="display: none;"></div>
<script>
    CLARITY.push({
        use: ['ads'],
        run: function(Ads) {
            Ads.site_code = "thr";
            Ads.zone = "";

            var keywords = [];

            // Keyword injection
            if (typeof(global_keywords) !== "undefined") {
                keywords = global_keywords;
            }

                            keywords.push({
                    keywords: "",
                    keyvalues: "tags=live feed",
                    paths: "",
                    positions: "all"
                });
                            keywords.push({
                    keywords: "",
                    keyvalues: "tags=television",
                    paths: "",
                    positions: "all"
                });
                            keywords.push({
                    keywords: "",
                    keyvalues: "tags=stephen colbert",
                    paths: "",
                    positions: "all"
                });
                            keywords.push({
                    keywords: "",
                    keyvalues: "tags=trevor noah",
                    paths: "",
                    positions: "all"
                });
                            keywords.push({
                    keywords: "",
                    keyvalues: "tags=late night tv",
                    paths: "",
                    positions: "all"
                });
                            keywords.push({
                    keywords: "",
                    keyvalues: "page=1106007",
                    paths: "",
                    positions: "all"
                });
                            keywords.push({
                    keywords: "",
                    keyvalues: "env=prod",
                    paths: "",
                    positions: "all"
                });
                            keywords.push({
                    keywords: "",
                    keyvalues: "domain=www.hollywoodreporter.com",
                    paths: "",
                    positions: "all"
                });
            
            Ads.keywords = keywords;

                            Ads.autoPopulate();
                    }
    });
</script>
</body>
</html>
