
<!DOCTYPE html>
<html lang="en">
<head>
<script type='text/javascript'>var _sf_startpt=(new Date()).getTime()</script>
<meta charset="utf-8">
<title>Childish Gambino&#039;s Album Sales Rise 419 Percent After &quot;This Is America&quot; Release, &#039;SNL&#039; Performance | Hollywood Reporter</title>
<meta name="viewport" content="width=device-width" />
<meta name="description" content="Three of his albums re-enter the Billboard 200 chart, led by &#039;Awaken, My Love!&#039;" />
<meta name="twitter:site" content="@THR" />
<meta name="twitter:creator" content="@THR" />
<meta name="twitter:url" content="https://www.billboard.com/articles/columns/chart-beat/8456106/childish-gambino-album-sales-rise-419-percent-this-is-america" />
<meta name="twitter:domain" content="https://www.hollywoodreporter.com/" />
<meta name="twitter:title" content="Childish Gambino&#039;s Album Sales Rise 419 Percent After &quot;This Is America&quot; Release, &#039;SNL&#039; Performance" />
<meta name="twitter:description" content="Three of his albums re-enter the Billboard 200 chart, led by &#039;Awaken, My Love!&#039;" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:image" content="https://cdn1.thr.com/sites/default/files/imagecache/NFE_Landscape/2018/05/donald_glover_snl.jpg" />
<meta property="og:site_name" content="The Hollywood Reporter" />
<meta property="og:title" content="Childish Gambino&#039;s Album Sales Rise 419 Percent After &quot;This Is America&quot; Release, &#039;SNL&#039; Performance" />
<meta property="og:description" content="Three of his albums re-enter the Billboard 200 chart, led by &#039;Awaken, My Love!&#039;" />
<meta property="og:url" content="https://www.hollywoodreporter.com/news/childish-gambinos-album-sales-rise-419-percent-is-america-release-snl-performance-1111956" />
<meta property="og:image" content="https://cdn1.thr.com/sites/default/files/2018/05/donald_glover_snl.jpg" />
<meta property="og:image:width" content="1296" />
<meta property="og:image:height" content="730" />
<meta property="og:image:type" content="image/jpeg" />
<meta property="og:type" content="article" />
<link rel="author" href="https://plus.google.com/+hollywoodreporter">
<link rel="canonical" href="https://www.billboard.com/articles/columns/chart-beat/8456106/childish-gambino-album-sales-rise-419-percent-this-is-america" />
<link rel="amphtml" href="https://www.hollywoodreporter.com/amp/https://www.billboard.com/articles/columns/chart-beat/8456106/childish-gambino-album-sales-rise-419-percent-this-is-america" />
<link rel="shortcut icon" href=" https://assets.hollywoodreporter.com/assets/1526333009/images/brand/favicon.ico?f1f3f2025d715580ce42">
<link rel="apple-touch-icon-precomposed" sizes="114x114" href=" https://assets.hollywoodreporter.com/assets/1526333009/images/brand/apple-touch-icon.png?f1f3f2025d715580ce42">
<script type="text/javascript">
    
    var PGM = window.PGM || {};
    PGM.config = PGM.config || {
        contentHost: "https://www.hollywoodreporter.com",
    };
    (function(PGM) {
        var debug_queue = [];
        PGM.debug = function() {debug_queue.push(arguments);};
        PGM.debug.dump = function() {return debug_queue;}
        PGM.debug.initialCategories = {
                    };
    })(PGM);

    PGM.events = (function() {
        var events_queue = [];
        return {
            trigger: function() {events_queue.push(arguments); },
            get: function() { return events_queue; }
        };
    })();

    PGM.createScript = (function() {
        var q = [], cs = function createScript() { q.push(arguments) };
        cs.dump = function() {return q;};
        return cs;
    })();

    PGM.createScriptTag = (function() {
        var q = [], cs = function createScriptTag() { q.push(arguments) };
        cs.dump = function() {return q;};
        return cs;
    })();

        PGM.tests = [];
    PGM.ads = PGM.ads || {};
    PGM.ads.adUnit = '/';
    PGM.ads.slots = PGM.ads.slots || {};

    PGM.gtmTrackerName = "ua"
</script>
<script src="https://ads.blbrd.co/advertisement.js"></script>

<script>
		    window.CLARITY_GPT_DELAY = 0.01 * 1000;
	
			clarityPageData = {"site_code":"thr","zone":"","disable_initial_load":true,"single_request_mode":true};
		
</script>
<script type="text/javascript">
    (function(){
        window.CLARITY = window.CLARITY || [];
        var ns = document.createElement('script'), s = document.getElementsByTagName('script')[0];
        ns.async = true; ns.type = 'text/javascript'; ns.src = '//lib.pgmcdn.com/clarity-1519742797700.min.js'; s.parentNode.insertBefore(ns, s);
    })();
</script>
<script>
	!function(a9,a,p,s,t,A,g){if(a[a9])return;function q(c,r){a[a9]._Q.push([c,r])}a[a9]={init:function(){q("i",arguments)},fetchBids:function(){q("f",arguments)},setDisplayBids:function(){},_Q:[]};A=p.createElement(s);A.async=!0;A.src=t;g=p.getElementsByTagName(s)[0];g.parentNode.insertBefore(A,g)}("apstag",window,document,"script","//c.amazon-adsystem.com/aax2/apstag.js");

	apstag.init({
        pubID: 3125,
        adServer: 'googletag',
        videoAdServer: 'DFP',
        bidTimeout: 600
    });

	// Tell Clarity not to load a9
    CLARITY.push({
        use: ['header'],
        run: function(header) {
            header.skipJsInject('a9');
        }
    });
</script>
<script>
                CLARITY.push({
                    use: ['header'],
                    run: function(header) {
                                                    var slotData = [
                                                                    ["m1_1", "6419/thr.com/music.article", [[300,250],[300,600]], "m1", {"980":[[300,250],[300,600]],"767":[],"0":[]}, 0],,                                                                    ["m2_1", "6419/thr.com/music.article", [[300,250]], "m2", {"980":[[300,250]],"767":[[300,250]],"0":[[300,250],[320,50]]}, 0],,                                                                    ["t_1", "6419/thr.com/music.article", [[728,90],[970,90],[970,250]], "t", {"980":[[728,90],[970,90],[970,250]],"767":[[728,90]],"0":[[320,50]]}, 0],                                                            ];

                            // Add header slots then run,
                            // any slots added after initial run will be processed differently
                            for(var i=0; i<slotData.length; i++) {
                                header.addHeaderSlot.apply(header, slotData[i]);
                            }
                        
                        header.run({"a9":{"account_id":3125}});
                    }
                });
            </script>
<script type="text/javascript">
    
    var PGM = window.PGM || {};
    PGM.mediaQueries = {
        medium: "only screen and (min-width: 768px)",
        large: "only screen and (min-width: 1024px)"
    };
    PGM.ads = PGM.ads || {};
    PGM.preta = false;
</script>
<script>
var THR = THR || {};
THR.config = THR.config || {
    contentHost: "https://www.hollywoodreporter.com",
    debug: "",
    mediaHost: "//cdn1.thr.com"
};
</script>

<script type='text/javascript'>
var googletag = googletag || {};
googletag.cmd = googletag.cmd || [];

var PGM = PGM || {};
PGM.ads = PGM.ads || {};
PGM.ads.data = {"ad_zone":"music.article","targeting":{"tags":["television","music","donald glover","saturday night live"],"page":"1111956","env":"prod"},"slots":{"t":{"adUnit":"6419\/thr.com\/music.article","slotName":"t","outOfBody":false,"responsive":true,"sizeMapping":{"980":[[728,90],[980,50],[970,90],[728,91],[980,250],[970,250],[970,66],[970,51],[970,251]],"767":[[728,90],[728,91]],"0":[[300,50],[300,51],[320,50],[320,51],[320,170]]},"defaultSizes":[[728,90],[980,50],[970,90],[728,91],[980,250],[970,250],[970,66],[970,51],[970,251]],"targetingParameters":{"pos":"t","tags":["television","music","donald glover","saturday night live"],"page":"1111956"},"chartLine":null,"lazyLoad":false},"t2":{"adUnit":"6419\/thr.com\/music.article","slotName":"t2","outOfBody":false,"responsive":true,"sizeMapping":{"980":[[644,380]],"767":[[644,380],[728,90],[728,91]],"0":[[300,50],[300,52],[300,300],[320,50],[320,52]]},"defaultSizes":[[644,380]],"targetingParameters":{"pos":"t2","tags":["television","music","donald glover","saturday night live"],"page":"1111956"},"chartLine":null,"lazyLoad":false},"b1":{"adUnit":"6419\/thr.com\/music.article","slotName":"b1","outOfBody":false,"responsive":true,"sizeMapping":{"980":[[88,31],[120,60]],"767":[[88,31],[120,60]],"0":[[88,31],[120,60]]},"defaultSizes":[[88,31],[120,60]],"targetingParameters":{"pos":"b1","tags":["television","music","donald glover","saturday night live"],"page":"1111956"},"chartLine":null,"lazyLoad":false},"o1":{"adUnit":"6419\/thr.com\/music.article","slotName":"o1","outOfBody":true,"responsive":false,"sizeMapping":[[]],"defaultSizes":[],"targetingParameters":{"pos":"o1","tags":["television","music","donald glover","saturday night live"],"page":"1111956"},"chartLine":null,"lazyLoad":false},"lightbox":{"adUnit":"6419\/thr.com\/music.article","slotName":"lightbox","outOfBody":false,"responsive":true,"sizeMapping":{"980":[[300,250],[300,600]],"767":[[728,90]],"0":[[320,50],[300,50]]},"defaultSizes":[[300,250],[300,600]],"targetingParameters":{"pos":"lightbox","tags":["television","music","donald glover","saturday night live"],"page":"1111956"},"chartLine":null,"lazyLoad":false},"m1":{"adUnit":"6419\/thr.com\/music.article","slotName":"m1","outOfBody":false,"responsive":true,"sizeMapping":{"980":[[300,250],[300,251],[300,600]],"767":[],"0":[]},"defaultSizes":[[300,250],[300,251],[300,600]],"targetingParameters":{"pos":"m1","tags":["television","music","donald glover","saturday night live"],"page":"1111956"},"chartLine":null,"lazyLoad":false},"m2":{"adUnit":"6419\/thr.com\/music.article","slotName":"m2","outOfBody":false,"responsive":true,"sizeMapping":{"980":[[300,250],[300,252]],"767":[[300,250],[300,252]],"0":[[300,250],[300,252],[300,50],[300,52],[320,50],[320,52]]},"defaultSizes":[[300,250],[300,252]],"targetingParameters":{"pos":"m2","tags":["television","music","donald glover","saturday night live"],"page":"1111956"},"chartLine":null,"lazyLoad":false}}};
PGM.ads.slots = PGM.ads.slots || {};
PGM.brightcove = {"account_id":769341148,"default_player":"rJWoNu3gLM","preta_player":"Sk0HS1WUf","amp_player":"rJWoNu3gLM","autoplayers":["VkzEx53Fg","rJIWUc7eW","4kXvKxBFg","r1La1160g","ByDcA7lvg"]};

CLARITY = CLARITY || [];

CLARITY.push({
    use: ["ads", "jquery"],
    run: function(Ads, $){
        if( typeof Krux !== 'undefined' ) {
            Ads.addKeyVal("all", "ksg", Krux.segments);
            Ads.addKeyVal("all", "kuid", Krux.user);
        }

        var $embeddedVideos = $('.embedded-content[data-template="video"]');
        if($embeddedVideos.length) {
            // Wish we could do this in the module but it's too late by then
            // for now all embedded videos are autoplay
            Ads.addKeyVal("all", "video", "autoplay");
        } else {
            // Else check if it's one of our autoplay videos
            $('video').each(function () {
                var $vid = $(this),
                    player = $vid.data('player'),
                    account = $vid.data('account');

                if (PGM.brightcove.autoplayers.indexOf(player) >= 0) {
                    // If there are any auto-play vids stop
                    Ads.addKeyVal("all", "video", "autoplay");
                    return false;
                } else if (account) {
                    Ads.addKeyVal("all", "video", "click-to-play");
                    // if there are click-to-plays there could still be an auto-play somewhere, continue
                }
            });
        }
    }
});
</script>
<script type='text/javascript'>
PGM.ads.adUnit = '/6419/thr.com/music.article';

CLARITY.push({
    use: ["ads"],
    run: function(Ads){
        Ads.addKeyVal("all", "zone", "music.article");
                            Ads.addKeyVal("all", "tags", ["television","music","donald glover","saturday night live"]);
                    Ads.addKeyVal("all", "page", "1111956");
                    Ads.addKeyVal("all", "env", "prod");
            }
});
</script>

<script>
    var _comscore = _comscore || [];
    var comscoreVars = {
        c1: "2"
        ,c2: "7395269"
        ,c3: ""
        };
    _comscore.push(comscoreVars);
    </script>
<script type="text/javascript" data-src="https://sb.scorecardresearch.com/beacon.js"></script>
<noscript>
    <img src="http://b.scorecardresearch.com/p?c1=2&c2=7395269&cv=2.0&cj=1" />
</noscript>


<script type="text/javascript">
        var dataLayer = dataLayer || [];
        dataLayer.push({
            'fireGTM': 'on'
                        , 'contentId': '1111956'

                    , 'contentType': 'news'

                    , 'author': 'Keith Caulfield, Billboard'

                    , 'category': ''

                    , 'tags': 'television, music, donald-glover, saturday-night-live'

                    , 'publishDate': '2018051508'

            
        });
        dataLayer.push({'gtm.start':new Date().getTime(),event:'gtm.js'});
        PGM.createScript('//www.googletagmanager.com/gtm.js?id=GTM-WLF8ZZ');
    </script>

<link rel="stylesheet" type="text/css" href="https://assets.hollywoodreporter.com/assets/1526333009/css/thr-lotr.css?f1f3f2025d715580ce42">
</head>
<body class="article-page" data-template="Article" data-adsitesection="Music" data-twitter-handle="thr">
<div class="header-wrapper ">
<header id="site-header" class="site-header " role="banner">
<div class="site-header__background">
<div class="site-header__contents">
<div class="site-header__bar">
<button class="site-header__nav-toggle"><i class="fa fa-bars"></i></button>
<h1 class="site-header__brand">
<a class="site-header__brand-link" href="/">
<img class="site-header__brand-logo" src="https://assets.hollywoodreporter.com/assets/1526333009/images/brand/thr-logo-white.svg?f1f3f2025d715580ce42" alt="The&#x20;Hollywood&#x20;Reporter">
<span class="site-header__brand-name">The Hollywood Reporter</span>
</a>
</h1>
<button class="site-header__search-toggle"><i class="fa fa-search"></i></button>
</div>
<nav class="site-header__nav">
<div class="site-header__nav-inner">
<ul class="site-header__nav-items">
<li class="site-header__nav-item ">
<a href=https&#x3A;&#x2F;&#x2F;www.hollywoodreporter.com&#x2F;movies class=site-header__nav-link>
Movies
</a>
</li>
<li class="site-header__nav-item ">
<a href=https&#x3A;&#x2F;&#x2F;www.hollywoodreporter.com&#x2F;node&#x2F;895551 class=site-header__nav-link>
TV
</a>
</li>
<li class="site-header__nav-item ">
<a href=https&#x3A;&#x2F;&#x2F;www.hollywoodreporter.com&#x2F;business class=site-header__nav-link>
Business
</a>
</li>
<li class="site-header__nav-item ">
<a href=https&#x3A;&#x2F;&#x2F;www.hollywoodreporter.com&#x2F;style class=site-header__nav-link>
Style
</a>
</li>
<li class="site-header__nav-item ">
<a href=https&#x3A;&#x2F;&#x2F;www.hollywoodreporter.com&#x2F;node&#x2F;859190 class=site-header__nav-link>
Politics
</a>
</li>
<li class="site-header__nav-item ">
<a href=https&#x3A;&#x2F;&#x2F;www.hollywoodreporter.com&#x2F;tech class=site-header__nav-link>
Tech
</a>
</li>
<li class="site-header__nav-item ">
<a href=https&#x3A;&#x2F;&#x2F;www.hollywoodreporter.com&#x2F;culture class=site-header__nav-link>
Culture
</a>
</li>
<li class="site-header__nav-item ">
<a href=https&#x3A;&#x2F;&#x2F;www.hollywoodreporter.com&#x2F;awards class=site-header__nav-link>
Awards
</a>
</li>
<li class="site-header__nav-item ">
<a href=https&#x3A;&#x2F;&#x2F;www.hollywoodreporter.com&#x2F;video class=site-header__nav-link>
Video
</a>
</li>
<li class="site-header__nav-item collapsed">
<span class=site-header__nav-link>
Sites
</span>
<span class="carat"></span><ul class="site-header__subnav-items">
<li class="site-header__subnav-item ">
<a href=https&#x3A;&#x2F;&#x2F;www.hollywoodreporter.com&#x2F;blogs&#x2F;heat-vision class=site-header__subnav-link>
Heat Vision
</a>
</li>
<li class="site-header__subnav-item ">
<a href=https&#x3A;&#x2F;&#x2F;www.hollywoodreporter.com&#x2F;blogs&#x2F;live-feed class=site-header__subnav-link>
Live Feed
</a>
</li>
<li class="site-header__subnav-item ">
<a href=https&#x3A;&#x2F;&#x2F;www.hollywoodreporter.com&#x2F;node&#x2F;786127 class=site-header__subnav-link>
Esq
</a>
</li>
<li class="site-header__subnav-item ">
<a href=https&#x3A;&#x2F;&#x2F;www.hollywoodreporter.com&#x2F;blogs&#x2F;race class=site-header__subnav-link>
The Race
</a>
</li>
<li class="site-header__subnav-item ">
<a href=https&#x3A;&#x2F;&#x2F;www.hollywoodreporter.com&#x2F;blogs&#x2F;behind-screen class=site-header__subnav-link>
Behind the Screen
</a>
</li>
<li class="site-header__subnav-item ">
<a href=https&#x3A;&#x2F;&#x2F;www.hollywoodreporter.com&#x2F;blogs&#x2F;bastard-machine class=site-header__subnav-link>
Bastard Machine
</a>
</li>
<li class="site-header__subnav-item ">
<a href=https&#x3A;&#x2F;&#x2F;www.hollywoodreporter.com&#x2F;node&#x2F;832202 class=site-header__subnav-link>
Rambling Reporter
</a>
</li>
<li class="site-header__subnav-item ">
<a href=https&#x3A;&#x2F;&#x2F;www.hollywoodreporter.com&#x2F;node&#x2F;832198 class=site-header__subnav-link>
The Fien Print
</a>
</li>
</ul>
</li>
</ul>
<a href="https://subscribe.hollywoodreporter.com/sub/?p=THR&amp;f=saleb&amp;s=IH1402HR12" class="site-header__nav-link site-header__nav-link--subscribe">Subscribe</a>
<a href="/newsletters/subscribe" class="site-header__nav-link site-header__nav-link--newsletter">Newsletters</a>
<ul class="site-header__nav-items site-header__nav-items--site-tools">
<li class="site-header__nav-item collapsed">
<span class=site-header__nav-link--site-tools&#x20;site-header__nav-link class=site-header__nav-link>
Site Tools
</span>
<span class="carat"></span><ul class="site-header__subnav-items">
<li class="site-header__subnav-item ">
<a href=https&#x3A;&#x2F;&#x2F;www.hollywoodreporter.com&#x2F;user&#x2F;login class=site-header__subnav-link>
Login
</a>
</li>
<li class="site-header__subnav-item ">
<a href=https&#x3A;&#x2F;&#x2F;www.hollywoodreporter.com&#x2F;daily&#x2F;archive class=site-header__subnav-link>
Daily Edition
</a>
</li>
</ul>
</li>
</ul>
</div>
</nav>
<form class="site-header__search-form" method="get" accept-charset="UTF-8" action="/search/">
<input class="site-header__search-input" placeholder="Search..." name="keys" maxlength="255">
<button id="site-header__search-submit" class="site-header__search-submit"><i class="fa fa-times"></i></button>
</form>
</div>
</div>
</header>
<div class="header-wrapper__secondary-header">
<div class="breaking-news-bar"></div>
</div>
</div>
<div class="site-header__placeholder"></div>
<div class="ad-container leaderboard leaderboard--top">
<div class="leaderboard-wrapper">
<div class="ad_desktop_placeholder">
<div class="ad_desktop_wrapper">
<div class='ad_desktop dfp-ad dfp-ad-t ' data-position='t' data-slot-name="t" data-sizes='[[728,90],[980,50],[970,90],[728,91],[980,250],[970,250],[970,66],[970,51],[970,251]]' data-size-mapping='{"980":[[728,90],[980,50],[970,90],[728,91],[980,250],[970,250],[970,66],[970,51],[970,251]],"767":[[728,90],[728,91]],"0":[[300,50],[300,51],[320,50],[320,51],[320,170]]}' data-lazy-load='' data-refresh='' data-refresh-timer='' data-targeting='{"pos":"t","tags":["television","music","donald glover","saturday night live"],"page":"1111956"}' data-ad-unit='6419/thr.com/music.article' data-trackaction="" data-tracklabel="Ad Click">
</div>
</div>
</div>
</div>
</div>
<div class='ad_desktop dfp-ad dfp-ad-o1 ' data-position='o1' data-slot-name="o1" data-sizes="[[1,1]]" data-out-of-page="true" data-lazy-load='' data-refresh='' data-refresh-timer='' data-targeting='{"pos":"o1","tags":["television","music","donald glover","saturday night live"],"page":"1111956"}' data-ad-unit='6419/thr.com/music.article' data-trackaction="" data-tracklabel="Ad Click">
</div>
<main class="article">
<section class="left-rail js-leftRail-container">
<div class="left-rail__list js-leftRail"></div>
<script type="application/json">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</script>
</section>
<section class="main-well js-mainWell">
<article class="article__content-well article__content-well--landscape js-revarticle url-breadcrumb is-active " data-id="1111956" data-url-breadcrumb="/news/childish-gambinos-album-sales-rise-419-percent-is-america-release-snl-performance-1111956" data-content-type="article" data-page-title="Childish&#x20;Gambino&#x27;s&#x20;Album&#x20;Sales&#x20;Rise&#x20;419&#x20;Percent&#x20;After&#x20;&quot;This&#x20;Is&#x20;America&quot;&#x20;Release,&#x20;&#x27;SNL&#x27;&#x20;Performance" data-canonical="https://www.billboard.com/articles/columns/chart-beat/8456106/childish-gambino-album-sales-rise-419-percent-this-is-america" data-chartbeatSection="music" data-analytics-category="" data-analytics-tags="Television, Music, Donald Glover, Saturday Night Live">
<div class="article__header">
<h1 class="article__headline">Childish Gambino&#039;s Album Sales Rise 419 Percent After &quot;This Is America&quot; Release, &#039;SNL&#039; Performance</h1>
<p class="article__meta">
<span class="js-publish-date" data-pubdate-value="2018051508">
8:20 AM PDT 5/15/2018
</span>
by
<span class="js-authors-list">
<span class="author">
Keith Caulfield, Billboard
</span> </span>
</p>
<ul class="social-share">
<li class="social-share__item">
<a class="js-pgm-social-share social-share__link social-share__link--facebook fa-facebook" data-pgm-share="facebook" data-pgm-title="Childish&#x20;Gambino&#x27;s&#x20;Album&#x20;Sales&#x20;Rise&#x20;419&#x20;Percent&#x20;After&#x20;&quot;This&#x20;Is&#x20;America&quot;&#x20;Release,&#x20;&#x27;SNL&#x27;&#x20;Performance" data-pgm-url="https&#x3A;&#x2F;&#x2F;www.billboard.com&#x2F;articles&#x2F;columns&#x2F;chart-beat&#x2F;8456106&#x2F;childish-gambino-album-sales-rise-419-percent-this-is-america" href="javascript:void(0);">
FACEBOOK
</a>
</li>
<li class="social-share__item">
<a class="js-pgm-social-share social-share__link social-share__link--twitter fa-twitter" data-pgm-share="twitter" data-pgm-title="Childish&#x20;Gambino&#x27;s&#x20;Album&#x20;Sales&#x20;Rise&#x20;419&#x20;Percent&#x20;After&#x20;&quot;This&#x20;Is&#x20;America&quot;&#x20;Release,&#x20;&#x27;SNL&#x27;&#x20;Performance" data-pgm-url="https&#x3A;&#x2F;&#x2F;www.billboard.com&#x2F;articles&#x2F;columns&#x2F;chart-beat&#x2F;8456106&#x2F;childish-gambino-album-sales-rise-419-percent-this-is-america" href="javascript:void(0);">
TWITTER
</a>
</li>
<li class="social-share__item">
<a class="social-share__link social-share__link--email fa-envelope" data-pgm-title="Childish&#x20;Gambino&#x27;s&#x20;Album&#x20;Sales&#x20;Rise&#x20;419&#x20;Percent&#x20;After&#x20;&quot;This&#x20;Is&#x20;America&quot;&#x20;Release,&#x20;&#x27;SNL&#x27;&#x20;Performance" href="mailto:?body=https&#x3A;&#x2F;&#x2F;www.billboard.com&#x2F;articles&#x2F;columns&#x2F;chart-beat&#x2F;8456106&#x2F;childish-gambino-album-sales-rise-419-percent-this-is-america&subject=Childish&#x20;Gambino&#x27;s&#x20;Album&#x20;Sales&#x20;Rise&#x20;419&#x20;Percent&#x20;After&#x20;&quot;This&#x20;Is&#x20;America&quot;&#x20;Release,&#x20;&#x27;SNL&#x27;&#x20;Performance">
EMAIL ME
</a>
</li>
<li class="social-share__item">
<a class="social-share__link social-share__link--print fa-print" target="_blank" href="/print/1111956">
PRINT
</a>
</li>
<li class="social-share__item">
<a class="social-share__link social-share__link--comments js-scroll-to-comments fa-comment" href="javascript:void(0);">
COMMENTS
</a>
</li>
</ul>
</div>
<figure class="main-media main-media--image " data-media-type="image" data-media-id="">
<div class="ndn_embed" data-config-distributor-id="91574" data-config-height="9/16w" id="ndn-video-player-1" style="width:100%;">
<img src="https://cdn1.thr.com/sites/default/files/imagecache/landscape_928x523/2018/05/donald_glover_snl.jpg" class="main-media__image">
<figcaption class="media__details-text">
<div class="media__credit">Screengrab/NBC</div>
</figcaption>
</div>
</figure>
<div class="article__body js-fitvids-content">
<div class='ad_desktop dfp-ad dfp-ad-m2 ' data-position='m2' data-slot-name="m2" data-sizes='[[300,250],[300,252]]' data-size-mapping='{"980":[[300,250],[300,252]],"767":[[300,250],[300,252]],"0":[[300,250],[300,252],[300,50],[300,52],[320,50],[320,52]]}' data-lazy-load='' data-refresh='' data-refresh-timer='' data-targeting='{"pos":"m2","tags":["television","music","donald glover","saturday night live"],"page":"1111956"}' data-ad-unit='6419/thr.com/music.article' data-trackaction="" data-tracklabel="Ad Click">
</div>
<h2 class="article__deck">
Three of his albums re-enter the Billboard 200 chart, led by 'Awaken, My Love!'
</h2>
<p>After a busy week for Donald Glover, and his musical alter ego Childish Gambino, the latter&rsquo;s album sales gained a whopping 419 percent in the U.S. in the week ending May 10, according to Nielsen Music. Glover hosted NBC&rsquo;s <em>Saturday Night Live</em> on May 5 and, during the show, performed his new buzzy single, &ldquo;This Is America,&quot; and released its much-discussed music video.</p>
<p>Collectively, Childish Gambino&rsquo;s catalog of albums sold 11,000 copies &mdash; up from just a little more than 2,000 in the week previous. (None of those albums includes the Billboard Hot 100-topping <em>This Is America</em>, though it is presumed to be featured on the musician&#39;s forthcoming new album.)</p>
<p>On the Billboard 200 chart dated May 19, three of the artist&#39;s albums re-enter the chart. His most recent release, <em>Awaken, My Love!</em>&nbsp;jumps back on at No. 45 with 12,000 equivalent album units earned (up 156 percent), with traditional album sales comprising 5,000 of that sum (up 268 percent). <em>Because the Internet</em> returns to the list at No. 61 (10,000 units; up 178 percent, with 3,000 in sales; up 681 percent), while <em>Camp</em> comes back on at No. 197 (5,000 units; up 174 percent, with 2,000 in sales; up 497 percent).</p>
<p>
<div class="embedded-content" data-nid="1111949" data-nodetype="news" data-template="readmore" data-amp-enabled="1">
<script type="application/json">
        {
          "nid": 1111949,
          "type": "news",
          "title": "Childish Gambino&#039;s &#039;This Is America&#039; Is YouTube&#039;s Biggest First Week Debut This Year",
          "path": "https://www.hollywoodreporter.com/news/childish-gambinos-is-america-is-youtubes-biggest-first-week-debut-year-1111949","media": {"width":919,"height":478,"extension":"png","file_size":374697,"mime_type":"image\/png","type":"image","path":"sites\/default\/files\/2018\/05\/screen_shot_2018-05-06_at_7.51.57_am.png","orientation":"landscape","id":null,"caption":null,"credit":"Screengrab"},
          "relative-path": "/news/childish-gambinos-is-america-is-youtubes-biggest-first-week-debut-year-1111949"
        }
      </script>
</div></p>
<p>In terms of total on-demand streams for the week ending May 10, Childish Gambino&#39;s songs collected 102.7 million clicks (in both video and audio streams) &mdash; up 487 percent. That figure includes the 65.3 million collected by &ldquo;This Is America.&rdquo; Even without the &ldquo;America&rdquo; streams, the rest of his songs still saw a robust 114 percent jump in streams.</p>
<p><em>This article originally appeared on <a href="https://www.billboard.com/articles/columns/chart-beat/8456106/childish-gambino-album-sales-rise-419-percent-this-is-america" target="_blank">Billboard</a>.&nbsp;</em></p>
</div>
<div class='ad_desktop dfp-ad dfp-ad-t2 ' data-position='t2' data-slot-name="t2" data-sizes='[[644,380]]' data-size-mapping='{"980":[[644,380]],"767":[[644,380],[728,90],[728,91]],"0":[[300,50],[300,52],[300,300],[320,50],[320,52]]}' data-lazy-load='' data-refresh='' data-refresh-timer='' data-targeting='{"pos":"t2","tags":["television","music","donald glover","saturday night live"],"page":"1111956"}' data-ad-unit='6419/thr.com/music.article' data-trackaction="" data-tracklabel="Ad Click">
</div>
<div class="article-meta-bottom">
<ul class="social-share social-share--bottom">
<li class="social-share__item">
<a class="js-pgm-social-share social-share__link social-share__link--facebook fa-facebook" data-pgm-share="facebook" data-pgm-title="Childish&#x20;Gambino&#x27;s&#x20;Album&#x20;Sales&#x20;Rise&#x20;419&#x20;Percent&#x20;After&#x20;&quot;This&#x20;Is&#x20;America&quot;&#x20;Release,&#x20;&#x27;SNL&#x27;&#x20;Performance" data-pgm-url="https&#x3A;&#x2F;&#x2F;www.billboard.com&#x2F;articles&#x2F;columns&#x2F;chart-beat&#x2F;8456106&#x2F;childish-gambino-album-sales-rise-419-percent-this-is-america" href="javascript:void(0);">
FACEBOOK
</a>
</li>
<li class="social-share__item">
<a class="js-pgm-social-share social-share__link social-share__link--twitter fa-twitter" data-pgm-share="twitter" data-pgm-title="Childish&#x20;Gambino&#x27;s&#x20;Album&#x20;Sales&#x20;Rise&#x20;419&#x20;Percent&#x20;After&#x20;&quot;This&#x20;Is&#x20;America&quot;&#x20;Release,&#x20;&#x27;SNL&#x27;&#x20;Performance" data-pgm-url="https&#x3A;&#x2F;&#x2F;www.billboard.com&#x2F;articles&#x2F;columns&#x2F;chart-beat&#x2F;8456106&#x2F;childish-gambino-album-sales-rise-419-percent-this-is-america" href="javascript:void(0);">
TWITTER
</a>
</li>
<li class="social-share__item">
<a class="social-share__link social-share__link--email fa-envelope" data-pgm-title="Childish&#x20;Gambino&#x27;s&#x20;Album&#x20;Sales&#x20;Rise&#x20;419&#x20;Percent&#x20;After&#x20;&quot;This&#x20;Is&#x20;America&quot;&#x20;Release,&#x20;&#x27;SNL&#x27;&#x20;Performance" href="mailto:?body=https&#x3A;&#x2F;&#x2F;www.billboard.com&#x2F;articles&#x2F;columns&#x2F;chart-beat&#x2F;8456106&#x2F;childish-gambino-album-sales-rise-419-percent-this-is-america&subject=Childish&#x20;Gambino&#x27;s&#x20;Album&#x20;Sales&#x20;Rise&#x20;419&#x20;Percent&#x20;After&#x20;&quot;This&#x20;Is&#x20;America&quot;&#x20;Release,&#x20;&#x27;SNL&#x27;&#x20;Performance">
EMAIL ME
</a>
</li>
<li class="social-share__item">
<a class="social-share__link social-share__link--print fa-print" target="_blank" href="/print/1111956">
PRINT
</a>
</li>
<li class="social-share__item">
<a class="social-share__link social-share__link--comments js-scroll-to-comments fa-comment" href="javascript:void(0);">
COMMENTS
</a>
</li>
</ul>
<ul class="article-meta__authors">
<li class="author">
<img src="https://cdn1.thr.com/sites/default/files/imagecache/nfe_square_383x383/2015/03/writerimage-thr.jpg" alt="Keith Caulfield, Billboard" class="author__image" />
<div class="author__details">
<p class="author__name">Keith Caulfield, Billboard</p>
<a href="mailto:THRnews@thr.com" class="author-social__email fa-envelope" data-tracklabel="Story Well - Author Email">THRnews@thr.com</a>
<a href="https://twitter.com/thr" class="author-social__twitter fa-twitter" data-tracklabel="Story Well - Author Twitter">@thr</a>
</div>
</li>
</ul>
</div>
<div class="zergnet-holder" data-placement="article"></div>
<div class="ad_desktop dfp-ad" data-position="zergnet" data-sizes="[[4,4]]" data-lazy-load="0" data-refresh="0" data-refresh-timer="0" data-swap="" data-load-order="" data-ad-unit="/6419/thr.com/zergnet">
</div>
<button class="js-show-disqus-comments show-disqus-comments" data-tracklabel="Show Comments - Childish Gambino&#039;s Album Sales Rise 419 Percent After &quot;This Is America&quot; Release, &#039;SNL&#039; Performance">Comments</button>
<div id="disqus-comments" class="disqus">
<div id="disqus_thread" class="disqus-comments-wrapper"></div>
<script type="text/javascript">
        var disqus_shortname = 'hollywoodreporter';
        var disqus_identifier = 'node/1111956';
        var disqus_title = 'Childish Gambinos Album Sales Rise 419 Percent After &quot;This Is America&quot; Release, SNL Performance';
        var disqus_url = 'https://www.billboard.com/articles/columns/chart-beat/8456106/childish-gambino-album-sales-rise-419-percent-this-is-america';
    </script>
<script data-src="//hollywoodreporter.disqus.com/embed.js"></script>
<a href="https://disqus.com" class="dsq-brlink">comments powered by <span class="logo-disqus">Disqus</span></a>
</div>
<div class='js-leftRail-slot-m1' data-position='m1' data-slot-name="m1" data-sizes='[[300,250],[300,251],[300,600]]' data-size-mapping='{"980":[[300,250],[300,251],[300,600]],"767":[],"0":[]}' data-lazy-load='' data-refresh='' data-refresh-timer='' data-targeting='{"pos":"m1","tags":["television","music","donald glover","saturday night live"],"page":"1111956"}' data-ad-unit='6419/thr.com/music.article' data-trackaction="" data-tracklabel="Ad Click">
</div>
<div class="js-ad-pageTargeting">
<script type="application/json">
        {
                            "tags": ["television","music","donald glover","saturday night live"],
                            "page": "1111956",
                            "env": "prod"
                    }
        </script>
</div>
</article>
<div class="js-leftRail-loadNewContent" data-currentId="1111956" data-urlPrefix="/fe_data"></div>
</section>
</main>
 
<footer id="site-footer" class="site-footer">
<div class="container">
<div class="branding column">
<div class="brand">
<a href="/" title="The Hollywood Reporter" rel="home" class="logo" data-tracklabel="Drip Pan Footer - THR Logo">The Hollywood Reporter</a>
</div>
<p class="copyright date">
&copy; 2018 The Hollywood Reporter
<br>
All rights reserved.
</p>
<p class="copyright terms">
<a href="/legal/terms">Terms of Use</a> |
<a href="/legal/privacy">Privacy</a> |
<a href="/sitemap">Sitemap</a> |
<a href="/legal/about-our-ads">About Our Ads</a>
</p>
</div>
<div class="affiliate column">
<ul>
<li>
<a href="/about/about" data-tracklabel="Drip Pan Footer - About Us">About Us</a>
</li>
<li>
<a href="/user/login" data-tracklabel="Drip Pan Footer - Login">Login</a>
</li>
<li>
<a href="/daily/archive" data-tracklabel="Drip Pan Footer - Daily Edition">Daily Edition</a>
</li>
<li>
<a href="https://www.hollywoodreporter.com/subscribe3" data-tracklabel="Drip Pan Footer - Subscribe">Subscribe</a>
</li>
<li>
<a href="/services" data-tracklabel="Drip Pan Footer - Subscriber Services">Subscriber Services</a>
</li>
<li>
<a href="//shop.hollywoodreporter.com" data-tracklabel="Drip Pan Footer - Back Issues">Back Issues</a>
</li>
<li>
<a href="/ad/contacts" data-tracklabel="Drip Pan Footer - Advertising">Advertising</a>
</li>
<li>
<a href="/contact" data-tracklabel="Drip Pan Footer - Contact Us">Contact Us</a>
</li>
<li>
<a href="http://prometheusglobalmedia.applytojob.com/" target="_blank" data-tracklabel="Drip Pan Footer - Careers">Careers</a>
</li>
<li>
<a href="/industry-jobs" data-tracklabel="Drip Pan Footer - Industry Jobs">Industry Jobs</a>
</li>
</ul>
</div>
<div class="follow column">
<ul>
<li>
Follow Us On
<a href="https://twitter.com/thr" target="_blank" data-tracklabel="Drip Pan Footer - Twitter">Twitter</a>
</li>
<li>
Find Us On
<a href="https://www.facebook.com/HollywoodReporter" target="_blank" data-tracklabel="Drip Pan Footer - Facebook">Facebook</a>
</li>
<li>
Watch Us On
<a href="https://www.youtube.com/thrnetwork" target="_blank" data-tracklabel="Drip Pan Footer - YouTube">Youtube</a>
</li>
</ul>
</div>
<div class="partner column">
<div class="publications">
<p>Our affiliate publications</p>
<ul>
<li>
<a href="http://www.billboard.com/" target="_blank" class="footer logo billboard" data-tracklabel="Drip Pan Footer - Billboard">Billboard</a>
</li>
<li>
<a href="https://www.vibe.com/" target="_blank" class="foot logo vibe" data-tracklabel="Drip Pan Footer - Vibe">Vibe</a>
</li>
<li>
 <a href="https://www.spin.com/" target="_blank" class="foot logo spin" data-tracklabel="Drip Pan Footer - Spin">Spin</a>
</li>
<li>
<a href="https://www.stereogum.com/" target="_blank" class="foot logo stereogum" data-tracklabel="Drip Pan Footer - Stereogum">Stereogum</a>
</li>
</ul>
</div>
</div>
</div>
</footer>
<script type="application/ld+json">
{
    "@context": "http://schema.org",
    "@type": "Organization",
    "name": "The Hollywood Reporter",
    "url": "http://www.hollywoodreporter.com",
    "logo": "http://www.hollywoodreporter.com/assets/images/brand/thr-logo.gif",
    "sameAs" : [
        "https://www.youtube.com/user/thrnetwork",
        "https://twitter.com/thr",
        "https://www.facebook.com/HollywoodReporter",
        "https://instagram.com/hollywoodreporter/"
    ]
}
</script>
<script type="text/javascript" src="https://assets.hollywoodreporter.com/assets/1526333009/js/commons.bundle.js?f1f3f2025d715580ce42"></script>
<script type="text/javascript" src="https://assets.hollywoodreporter.com/assets/1526333009/js/transition.bundle.js?f1f3f2025d715580ce42"></script>
<script type="text/javascript" src="https://assets.hollywoodreporter.com/assets/1526333009/js/templates.js?f1f3f2025d715580ce42"></script>
<script type="text/javascript" src="https://assets.hollywoodreporter.com/assets/1526333009/js/vendor.js?f1f3f2025d715580ce42"></script>
<script type="text/javascript" src="https://assets.hollywoodreporter.com/assets/1526333009/js/home.bundle.js?f1f3f2025d715580ce42"></script>
<script type="text/javascript" src="https://assets.hollywoodreporter.com/assets/1526333009/js/thr.js?f1f3f2025d715580ce42"></script>
<div id="fb-root"></div>
<script type="text/javascript">
    PGM.createScriptTag("//connect.facebook.net/en_US/sdk.js#xfbml=1&version=v2.6&appId=303838389949803");
</script>
<script type="text/javascript">var __st_loadLate=true;</script>
<meta name="sailthru.title" content="Childish Gambino&#039;s Album Sales Rise 419 Percent After &quot;This Is America&quot; Release, &#039;SNL&#039; Performance">
<meta name="sailthru.description" content="Three of his albums re-enter the Billboard 200 chart, led by &#039;Awaken, My Love!&#039;">
<meta name="sailthru.author" content="Keith Caulfield, Billboard">
<meta name="sailthru.date" content="2018-05-15 08:20:20">
<meta name="sailthru.tags" content="Television,Music,Donald Glover,Saturday Night Live">
<script type="text/javascript">
    PGM.createScript("//ak.sail-horizon.com/horizon/v1.js", function() {
        if (window.Sailthru) {
            PGM.debug('sailthru', 'Running Sailthru.track for', 'https://www.billboard.com/articles/columns/chart-beat/8456106/childish-gambino-album-sales-rise-419-percent-this-is-america');
            Sailthru.track({
                domain: 'horizon.hollywoodreporter.com',
                spider: true,
                track_url: true,
                url: 'https://www.billboard.com/articles/columns/chart-beat/8456106/childish-gambino-album-sales-rise-419-percent-this-is-america'
            });
        }
        else {
            PGM.debug('sailthru', 'No window.Sailthru');
        }
    });
    </script>
<script type="text/javascript">
    PGM.createScript("//dnn506yrbagrg.cloudfront.net/pages/scripts/0021/6696.js?"+Math.floor(new Date().getTime()/3600000));
</script>

<script type='text/javascript'>
    var _sf_async_config={};
    /** CONFIGURATION START **/
    _sf_async_config.uid = 3388;
    _sf_async_config.domain = 'hollywoodreporter.com';
    _sf_async_config.useCanonical = true;
    _sf_async_config.authors = "Keith Caulfield, Billboard";
    _sf_async_config.sections = "music";
    /** CONFIGURATION END **/
    PGM.createScript('//static.chartbeat.com/js/chartbeat.js');
</script>



<script class="kxct" data-id="JtjzpxpZ" data-timing="async" data-version="1.9" type="text/javascript">
    window.Krux||((Krux=function(){Krux.q.push(arguments)}).q=[]);
    (function(){
        var k=document.createElement('script');k.type='text/javascript';k.async=true;
        k.src=(location.protocol==='https:'?'https:':'http:')+'//cdn.krxd.net/controltag/JtjzpxpZ.js';
        var s=document.getElementsByTagName('script')[0];s.parentNode.insertBefore(k,s);
    }());
</script>

<script class="kxint" type="text/javascript">
window.Krux||((Krux=function(){Krux.q.push(arguments);}).q=[]);
(function(){
  function retrieve(n){
    var k= 'kx'+''+n, ls=(function(){
      try {
        return window.localStorage;
      } catch(e) {
        return null;
      }
    })();
    if (ls) {
        return ls[k] || '';
    } else if (navigator.cookieEnabled) {
        var m = document.cookie.match(k+'=([^;]*)');
        return (m && unescape(m[1])) || '';
    } else {
        return '';
    }
  }
  Krux.user = retrieve('user');
  var segs = retrieve('segs');
  Krux.segments = segs ? segs.split(',') : [];
})();
</script>

<script type="text/javascript">
        PGM.createScript('//launch.newsinc.com/js/embed.js', function() {
            if( _informq && typeof _informq.push === 'function' ) {
                _informq.push(['embed']);
            }
        });
    </script>
<script>
    window.CLARITY = window.CLARITY || [];
</script>
<div class="ad_clarity" data-out-of-page="true" style="display: none;"></div>
<script>
    CLARITY.push({
        use: ['ads'],
        run: function(Ads) {
            Ads.site_code = "thr";
            Ads.zone = "";

            var keywords = [];

            // Keyword injection
            if (typeof(global_keywords) !== "undefined") {
                keywords = global_keywords;
            }

                            keywords.push({
                    keywords: "",
                    keyvalues: "tags=television",
                    paths: "",
                    positions: "all"
                });
                            keywords.push({
                    keywords: "",
                    keyvalues: "tags=music",
                    paths: "",
                    positions: "all"
                });
                            keywords.push({
                    keywords: "",
                    keyvalues: "tags=donald glover",
                    paths: "",
                    positions: "all"
                });
                            keywords.push({
                    keywords: "",
                    keyvalues: "tags=saturday night live",
                    paths: "",
                    positions: "all"
                });
                            keywords.push({
                    keywords: "",
                    keyvalues: "page=1111956",
                    paths: "",
                    positions: "all"
                });
                            keywords.push({
                    keywords: "",
                    keyvalues: "env=prod",
                    paths: "",
                    positions: "all"
                });
                            keywords.push({
                    keywords: "",
                    keyvalues: "domain=www.hollywoodreporter.com",
                    paths: "",
                    positions: "all"
                });
            
            Ads.keywords = keywords;

                            Ads.autoPopulate();
                    }
    });
</script>
</body>
</html>
